Degraded O365 job performance

Incident Report for m108

Resolved

The issue has been resolved.
Posted Feb 27, 2026 - 15:39 UTC

Identified

We have identified an issue impacting O365 job performance. Our team is actively working to resolve the issue as quickly as possible.
Posted Feb 26, 2026 - 11:36 UTC
This incident affected: Office 365 (West Europe, France Central, Switzerland North, South Africa North, Italy North).