O365 Usage Calculation
Incident Report for m108
Resolved
This incident has been resolved.
Posted Sep 23, 2024 - 13:52 UTC
Identified
Some customers might observe a decrease in their Office 365 current usage when their configurations are set for All Backed-up versions capacity calculations. We’re aware of this issue and are addressing it in this weekend's maintenance. We apologize for the inconvenience.
Posted Sep 13, 2024 - 14:43 UTC